やっぱJDKは8に限るね。
自称LTSの11とか、ましてその他の寿命半年の雑魚バージョンはスルーでおk。だいたいsqldeveloperに同梱されてるの8だし。総本山Oracle様その人ですらまだ切り替え不要と判断しているのである。Apache Commonsを標準ライブラリ化したようなシンタックスシュガーばっか沢山増えてるけどコードゴルファーしか使わないよどうせ。Oracleのセールスマンが散々煽ってたモジュールなど誰も、Oracle自身のプロダクトですら使ってないやんけ。var?寧ろ読み難くなるからアレは使ってはいかん。ちなみにLombokとGS Collections万歳。
まぁ結局、トラブルはライブラリを前回トラブルと同様に指定して直ったんだが、実はそれ以前の問題、またEclipseがインポートしたプロジェクトをJavaプロジェクトと認識しなくなっていた事象で苦労した。
そろそろ本当にEclipseのプロジェクト構成を見直さないと駄目かもしれぬ…。アレは我ながら雑だったからな…。